const regex = /\A\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A\\s+', 'g')
const str = `
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);