use strict;
my $str = '
';
my $regex = qr/\A\s+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";