using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\""\w*\""\:\[\d*\.\d*\,\d*\.\d*\]\,\""t\""\:2\}";
string input = @"{""location"":[55.32168,140.556],""t"":2}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}