package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{\"\w*\"\:\[\d*\.\d*\,\d*\.\d*\]\,\"t\"\:2\}`)
var str = `{"location":[55.32168,140.556],"t":2}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}