$re = '/^<svg[^>]*?\sxmlns=([\'"`])https?\:\/\/www\.w3\.org\/2000\/svg\1[^>]*>/m';
$str = '<svg xmlns="http://www.w3.org/2000/svg">
<svg xmlns=\'http://www.w3.org/2000/svg\'>
<svg xmlns=`http://www.w3.org/2000/svg`>
<svg xmlns="http://www.w3.org/2000/svg">
<svg xmlns=\'http://www.w3.org/2000/svg\'>
<svgXxmlns="http://www.w3.org/2000/svg">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);