re = /^<svg[^>]*?\sxmlns=(['"`])https?\:\/\/www\.w3\.org\/2000\/svg\1[^>]*>/m
str = '<svg xmlns="http://www.w3.org/2000/svg">
<svg xmlns=\'http://www.w3.org/2000/svg\'>
<svg xmlns=`http://www.w3.org/2000/svg`>
<svg xmlns="http://www.w3.org/2000/svg">
<svg xmlns=\'http://www.w3.org/2000/svg\'>
<svgXxmlns="http://www.w3.org/2000/svg">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end