import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(href|src)\\=\\\"(?!(ht|f)tp|www|:|\\/\\/|[^\"]*\\.com)";
final String string = "href=\"/hello\n"
+ "href=\"hello/bob\n"
+ "href=\"new/hello/bob\n"
+ "href=\"abc.hello.com/hello\n"
+ "href=\"www.google.com/hello\n"
+ "href=\"https://www.google.com\n"
+ "href=\"http://google.com\n"
+ "href=\"ftp://www.google.com\n"
+ "href=\"://google.com\n"
+ "href=\"//google.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}