$re = '/(href|src)\=\"(?!(ht|f)tp|www|:|\/\/|[^"]*\.com)/';
$str = 'href="/hello
href="hello/bob
href="new/hello/bob
href="abc.hello.com/hello
href="www.google.com/hello
href="https://www.google.com
href="http://google.com
href="ftp://www.google.com
href="://google.com
href="//google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);