import Foundation
let pattern = #"(href|src)\=\"(?!(ht|f)tp|www|:|\/\/|[^"]*\.com)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
href="/hello
href="hello/bob
href="new/hello/bob
href="abc.hello.com/hello
href="www.google.com/hello
href="https://www.google.com
href="http://google.com
href="ftp://www.google.com
href="://google.com
href="//google.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)