const regex = new RegExp('(\\")?(\\')?(?(1)(\\w+\\")|(?(2)(\\w+\\')|(?=\\b^$\\b)))', 'gm')
const str = `"hello" 'world' "hola' 'mundo"
\\0
\\0\\n
.
*
.*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}