$re = '/(\")?(\')?(?(1)(\w+\")|(?(2)(\w+\')|(?=\b^$\b)))/m';
$str = '"hello" \'world\' "hola\' \'mundo"
\\0
\\0\\n
.
*
.*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);