re = /(\")?(')?(?(1)(\w+\")|(?(2)(\w+')|(?=\b^$\b)))/m
str = '"hello" \'world\' "hola\' \'mundo"
\\0
\\0\\n
.
*
.*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end