#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i:\.jpe?g)$"
Local $sString = "/home/my/siteblog" & @CRLF & _
"/home/my/siteblog/img/example.jpg" & @CRLF & _
"/home/my/siteblog/img/example.JPG" & @CRLF & _
"/home/my/siteblog/img/example.jpeg" & @CRLF & _
"/home/my/siteblog/img/example.jpEG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")