re = /(?i:\.jpe?g)$/m
str = '/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/example.jpeg
/home/my/siteblog/img/example.jpEG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end