package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i:\.jpe?g)$`)
var str = `/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/example.jpeg
/home/my/siteblog/img/example.jpEG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}