package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{5}(?:[-\s]\d{4})?`)
var str = `2512 Wildwood Crossings, Birmingham, AL 35211-6401`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}