$re = '/\d{5}(?:[-\s]\d{4})?/m';
$str = '2512 Wildwood Crossings, Birmingham, AL 35211-6401';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);