re = /\d{5}(?:[-\s]\d{4})?/m
str = '2512 Wildwood Crossings, Birmingham, AL 35211-6401'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end