using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\b((?:[Vv][ao]n|(?:[Dd][eu]\s+)?[Ll]a|[Dd][eu]|St\.|Auf\s+der)\s+\p{L}+)(.*)";
string input = @"Emile La Sére
George A. La Dow
Gilbert De La Matyr
Robert M. La Follette
William Leroy La Follette
Robert M. La Follette Sr.
Robert M. La Follette Jr.
Charles M. La Follette
Monica De La Cruz
David A. De Armond
Justin De Witt Bowersock
De Witt C. Giddings
Julien de Lallande Poydras
Henry St. John
Edward St. Loe Livermore
Oscar L. Auf der Heide
Kika de la Garza";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}