import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\b((?:[Vv][ao]n|(?:[Dd][eu]\\s+)?[Ll]a|[Dd][eu]|St\\.|Auf\\s+der)\\s+\\p{L}+)(.*)";
final String string = "Emile La Sére\n"
+ "George A. La Dow\n"
+ "Gilbert De La Matyr\n"
+ "Robert M. La Follette\n"
+ "William Leroy La Follette\n"
+ "Robert M. La Follette Sr.\n"
+ "Robert M. La Follette Jr.\n"
+ "Charles M. La Follette\n"
+ "Monica De La Cruz\n"
+ "David A. De Armond\n"
+ "Justin De Witt Bowersock\n"
+ "De Witt C. Giddings\n"
+ "Julien de Lallande Poydras\n"
+ "Henry St. John\n"
+ "Edward St. Loe Livermore\n"
+ "Oscar L. Auf der Heide\n"
+ "Kika de la Garza";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}