import re
regex = re.compile(r"^(.*?)\b((?:[Vv][ao]n|(?:[Dd][eu]\s+)?[Ll]a|[Dd][eu]|St\.|Auf\s+der)\s+\p{L}+)(.*)", flags=re.MULTILINE | re.UNICODE)
test_str = ("Emile La Sére\n"
"George A. La Dow\n"
"Gilbert De La Matyr\n"
"Robert M. La Follette\n"
"William Leroy La Follette\n"
"Robert M. La Follette Sr.\n"
"Robert M. La Follette Jr.\n"
"Charles M. La Follette\n"
"Monica De La Cruz\n"
"David A. De Armond\n"
"Justin De Witt Bowersock\n"
"De Witt C. Giddings\n"
"Julien de Lallande Poydras\n"
"Henry St. John\n"
"Edward St. Loe Livermore\n"
"Oscar L. Auf der Heide\n"
"Kika de la Garza")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")