import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b\\d{1,2}\\b)";
final String string = "input_text = \"Serian 4 unidades de mermelada para el dia 04 del 8 de este año 2023\" #example 1\n"
+ "input_text = \"Hay 10 unidades para el dia 15 del 12 y seran 9 ya para el 7 de noviembre\" #example 2\n"
+ "input_text = \"Hay 10 unidades para el 15 del 1º mes del año y seran alrededor de 9 para el 7º dia del mes de noviembre\" #example 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}