import re
regex = re.compile(r"(\b\d{1,2}\b)", flags=re.MULTILINE)
test_str = ("input_text = \"Serian 4 unidades de mermelada para el dia 04 del 8 de este año 2023\" #example 1\n"
"input_text = \"Hay 10 unidades para el dia 15 del 12 y seran 9 ya para el 7 de noviembre\" #example 2\n"
"input_text = \"Hay 10 unidades para el 15 del 1º mes del año y seran alrededor de 9 para el 7º dia del mes de noviembre\" #example 3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")