// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b\d{1,2}\b)").unwrap();
let string = "input_text = \"Serian 4 unidades de mermelada para el dia 04 del 8 de este año 2023\" #example 1
input_text = \"Hay 10 unidades para el dia 15 del 12 y seran 9 ya para el 7 de noviembre\" #example 2
input_text = \"Hay 10 unidades para el 15 del 1º mes del año y seran alrededor de 9 para el 7º dia del mes de noviembre\" #example 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}