import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "r\\s*g\\s*b\\s*\\(\\s*(?:1?\\d{1,2}|2[0-4]\\d|25[0-5])\\s*(?:,\\s*(?:1?\\d{1,2}|2[0-4]\\d|25[0-5])\\s*){2}\\)\\s*;?";
final String string = "rgb(255, 240, 0);\n"
+ "rgb(0,0, 0)\n"
+ "rgb ( 0,12,0)\n"
+ "r gb(12,24,26 ) ;\n"
+ "rgb(256,2,76);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}