const regex = /r\s*g\s*b\s*\(\s*(?:1?\d{1,2}|2[0-4]\d|25[0-5])\s*(?:,\s*(?:1?\d{1,2}|2[0-4]\d|25[0-5])\s*){2}\)\s*;?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('r\\s*g\\s*b\\s*\\(\\s*(?:1?\\d{1,2}|2[0-4]\\d|25[0-5])\\s*(?:,\\s*(?:1?\\d{1,2}|2[0-4]\\d|25[0-5])\\s*){2}\\)\\s*;?', 'g')
const str = `rgb(255, 240, 0);
rgb(0,0, 0)
rgb ( 0,12,0)
r gb(12,24,26 ) ;
rgb(256,2,76);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}