$re = '/r\s*g\s*b\s*\(\s*(?:1?\d{1,2}|2[0-4]\d|25[0-5])\s*(?:,\s*(?:1?\d{1,2}|2[0-4]\d|25[0-5])\s*){2}\)\s*;?/';
$str = 'rgb(255, 240, 0);
rgb(0,0, 0)
rgb ( 0,12,0)
r gb(12,24,26 ) ;
rgb(256,2,76);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);