#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".+(#\d+ )"
Local $sString = " john#456 18 mai 2017 11:01" & @CRLF & _
"test123#123 18 mai 2017 11:01" & @CRLF & _
"michael#4561218 mai 2017 11:01" & @CRLF & _
"'(çà'_(fdlfsnd#456 18 mai 2017 11:01" & @CRLF & _
"lrjdlfddfdf#456 18 mai 2017 11:01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")