package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.+(#\d+ )`)
var str = ` john#456 18 mai 2017 11:01
test123#123 18 mai 2017 11:01
michael#4561218 mai 2017 11:01
'(çà'_(fdlfsnd#456 18 mai 2017 11:01
lrjdlfddfdf#456 18 mai 2017 11:01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}