re = /.+(#\d+ )/
str = ' john#456 18 mai 2017 11:01
test123#123 18 mai 2017 11:01
michael#4561218 mai 2017 11:01
\'(çà\'_(fdlfsnd#456 18 mai 2017 11:01
lrjdlfddfdf#456 18 mai 2017 11:01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end