#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:https?:)?(?:\/\/)?(?:[0-9A-Z-]+\.)?(?:youtu\.be\/|youtube(?:-nocookie)?\.com\/\S*?[^\w\s-])((?!videoseries)[\w-]{11})(?=[^\w-]|$)(?![?=&+%\w.-]*(?:['"][^<>]*>|<\/a>))[?=&+%\w.-]*"
Local $sString = "<p>asdad youtube" & @CRLF & _
"</p><div><br />" & @CRLF & _
"youtube: https://www.youtube.com/watch?v=HAKp1hyeaFU " & @CRLF & _
"https://www.youtube.com/watch?v=itc07uJ2LKM&feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6&v=itc07uJ2LKM" & @CRLF & _
"</div>" & @CRLF & _
"<div>daadsads</div>" & @CRLF & _
"" & @CRLF & _
"<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>" & @CRLF & _
"" & @CRLF & _
"<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>" & @CRLF & _
"" & @CRLF & _
"<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<div>https://youtu.be/j2uN5Jeblf4</div>" & @CRLF & _
"" & @CRLF & _
"https://www.youtube-nocookie.com/embed/ghAYTa0MFbM?controls=0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")