import re
regex = re.compile(r"(?:https?:)?(?:\/\/)?(?:[0-9A-Z-]+\.)?(?:youtu\.be\/|youtube(?:-nocookie)?\.com\/\S*?[^\w\s-])((?!videoseries)[\w-]{11})(?=[^\w-]|$)(?![?=&+%\w.-]*(?:['\"][^<>]*>|<\/a>))[?=&+%\w.-]*", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("<p>asdad youtube\n"
"</p><div><br />\n"
"youtube: https://www.youtube.com/watch?v=HAKp1hyeaFU \n"
"https://www.youtube.com/watch?v=itc07uJ2LKM&feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6\n\n"
"https://www.youtube.com/watch?feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6&v=itc07uJ2LKM\n"
"</div>\n"
"<div>daadsads</div>\n\n"
"<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>\n\n"
"<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>\n\n"
"<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>\n\n\n"
"<div>https://youtu.be/j2uN5Jeblf4</div>\n\n"
"https://www.youtube-nocookie.com/embed/ghAYTa0MFbM?controls=0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")