import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:)?(?:\\/\\/)?(?:[0-9A-Z-]+\\.)?(?:youtu\\.be\\/|youtube(?:-nocookie)?\\.com\\/\\S*?[^\\w\\s-])((?!videoseries)[\\w-]{11})(?=[^\\w-]|$)(?![?=&+%\\w.-]*(?:['\"][^<>]*>|<\\/a>))[?=&+%\\w.-]*";
final String string = "<p>asdad youtube\n"
+ "</p><div><br />\n"
+ "youtube: https://www.youtube.com/watch?v=HAKp1hyeaFU \n"
+ "https://www.youtube.com/watch?v=itc07uJ2LKM&feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6\n\n"
+ "https://www.youtube.com/watch?feature=push-u-sub&attr_tag=fdPXhNHdYCl8qsEg%3A6&v=itc07uJ2LKM\n"
+ "</div>\n"
+ "<div>daadsads</div>\n\n"
+ "<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>\n\n"
+ "<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>\n\n"
+ "<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>\n\n\n"
+ "<div>https://youtu.be/j2uN5Jeblf4</div>\n\n"
+ "https://www.youtube-nocookie.com/embed/ghAYTa0MFbM?controls=0";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}