#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\d[- \/.])(?<!\d)(3[01]|[12][0-9]|0?[1-9])[- \/.](1[012]|0?[1-9])[- \/.](?:\d{2})?(\d?\d)(?![- \/.]?\d)"
Local $sString = "Correct:" & @CRLF & _
"01/01/2000" & @CRLF & _
"01/Jan/2000" & @CRLF & _
"31/01/2000" & @CRLF & _
"31/Jan/2000" & @CRLF & _
"31.Jan.2000" & @CRLF & _
"31-Jan-2000" & @CRLF & _
"01/1/2000 x form" & @CRLF & _
"01/Jan/2000" & @CRLF & _
"01/1/01 x form" & @CRLF & _
"01/Jan/01" & @CRLF & _
"29/02/2000 x date" & @CRLF & _
"29/Feb/2000" & @CRLF & _
"28/02/2001" & @CRLF & _
"28/Feb/2001" & @CRLF & _
"30/04/2000" & @CRLF & _
"30/Apr/2000" & @CRLF & _
"31/07/2000" & @CRLF & _
"31/Jul/2000" & @CRLF & _
"31/08/2000" & @CRLF & _
"31/Aug/2000" & @CRLF & _
"01/12/2000" & @CRLF & _
"01/Dec/2000" & @CRLF & _
"" & @CRLF & _
"31-01-8888 ?" & @CRLF & _
"02/Jan-1984" & @CRLF & _
"1.1.0 x form" & @CRLF & _
"10.11.12" & @CRLF & _
"" & @CRLF & _
"all catched as x form" & @CRLF & _
"0,0,0" & @CRLF & _
"test 31.100.1952" & @CRLF & _
"32/03/18" & @CRLF & _
"1.2.3" & @CRLF & _
"123.2.12" & @CRLF & _
"_22.02.18_" & @CRLF & _
"22-02-18test" & @CRLF & _
"22/02-18" & @CRLF & _
"22//02/18" & @CRLF & _
"22 02-18" & @CRLF & _
"22:02:18" & @CRLF & _
"1,2,3" & @CRLF & _
"" & @CRLF & _
"False:" & @CRLF & _
"32/01/2000 x form" & @CRLF & _
"32/Jan/2000" & @CRLF & _
"01/15/2000 x form" & @CRLF & _
"29/02/2001 x date" & @CRLF & _
"29/Feb/2001" & @CRLF & _
"29/02/1900 x date" & @CRLF & _
"31/04/2000 x date" & @CRLF & _
"31/Apr/2000" & @CRLF & _
"31/09/2000 x date" & @CRLF & _
"31/Sep/2000" & @CRLF & _
"1.2.3-4" & @CRLF & _
"1-2-3.4" & @CRLF & _
"10.10.10.10" & @CRLF & _
"2w4w6" & @CRLF & _
"" & @CRLF & _
"... falls on the date of 10.11.12." & @CRLF & _
"... it.10.11.12 has some type - there should be a whitespace but ...."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")