import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d[- \\/.])(?<!\\d)(3[01]|[12][0-9]|0?[1-9])[- \\/.](1[012]|0?[1-9])[- \\/.](?:\\d{2})?(\\d?\\d)(?![- \\/.]?\\d)";
final String string = "Correct:\n"
+ "01/01/2000\n"
+ "01/Jan/2000\n"
+ "31/01/2000\n"
+ "31/Jan/2000\n"
+ "31.Jan.2000\n"
+ "31-Jan-2000\n"
+ "01/1/2000 x form\n"
+ "01/Jan/2000\n"
+ "01/1/01 x form\n"
+ "01/Jan/01\n"
+ "29/02/2000 x date\n"
+ "29/Feb/2000\n"
+ "28/02/2001\n"
+ "28/Feb/2001\n"
+ "30/04/2000\n"
+ "30/Apr/2000\n"
+ "31/07/2000\n"
+ "31/Jul/2000\n"
+ "31/08/2000\n"
+ "31/Aug/2000\n"
+ "01/12/2000\n"
+ "01/Dec/2000\n\n"
+ "31-01-8888 ?\n"
+ "02/Jan-1984\n"
+ "1.1.0 x form\n"
+ "10.11.12\n\n"
+ "all catched as x form\n"
+ "0,0,0\n"
+ "test 31.100.1952\n"
+ "32/03/18\n"
+ "1.2.3\n"
+ "123.2.12\n"
+ "_22.02.18_\n"
+ "22-02-18test\n"
+ "22/02-18\n"
+ "22//02/18\n"
+ "22 02-18\n"
+ "22:02:18\n"
+ "1,2,3\n\n"
+ "False:\n"
+ "32/01/2000 x form\n"
+ "32/Jan/2000\n"
+ "01/15/2000 x form\n"
+ "29/02/2001 x date\n"
+ "29/Feb/2001\n"
+ "29/02/1900 x date\n"
+ "31/04/2000 x date\n"
+ "31/Apr/2000\n"
+ "31/09/2000 x date\n"
+ "31/Sep/2000\n"
+ "1.2.3-4\n"
+ "1-2-3.4\n"
+ "10.10.10.10\n"
+ "2w4w6\n\n"
+ "... falls on the date of 10.11.12.\n"
+ "... it.10.11.12 has some type - there should be a whitespace but ....";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}