use strict;
my $str = ' \'84951234567\', \'+74951234567\', \'8-495-1-234-567\',
\' 8 (8122) 56-56-56\', \'8-911-1234567\', \'8 (911) 12 345 67\',
\'8-911 12 345 67\', \'8 (911) - 123 - 45 - 67\', \'+ 7 999 123 4567\',
\'8 ( 999 ) 1234567\', \'8 999 123 4567\'';
my $regex = qr/[78]( --[(][)]*[0-9]{10})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}