#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((marque)\s?(un)?\s?(but|doublé|triplé)?\s?(à)?\s?(la)?\s?[0-9]?[0-9]?(ème)?)"
Local $sString = "Hunou marque" & @CRLF & _
"Max marque un but à la 4ème" & @CRLF & _
"ki marque un doublé à la 45ème minute" & @CRLF & _
"Hunou marque triplé"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")