const regex = /((marque)\s?(un)?\s?(but|doublé|triplé)?\s?(à)?\s?(la)?\s?[0-9]?[0-9]?(ème)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((marque)\\s?(un)?\\s?(but|doublé|triplé)?\\s?(à)?\\s?(la)?\\s?[0-9]?[0-9]?(ème)?)', 'gm')
const str = `Hunou marque
Max marque un but à la 4ème
ki marque un doublé à la 45ème minute
Hunou marque triplé`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}