package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?\d+(?:\.\d*(?:[eE][+-]?\d+)?)?$`)
var str = `10000
1.0E7
1.
1.355
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}