// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[+-]?\d+(?:\.\d*(?:[eE][+-]?\d+)?)?$").unwrap();
let string = "10000
1.0E7
1.
1.355
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}