#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/tax-efficient-(guide|investing)|\/tax-raid-high-earners"
Local $sString = "<!-- INSTAPAGE: Paths only -->" & @CRLF & _
"/" & @CRLF & _
"/tax-efficient-guide" & @CRLF & _
"/tax-efficient-investing" & @CRLF & _
"/tax-efficient-guide-download" & @CRLF & _
"/tax-raid-high-earners" & @CRLF & _
"/tax-raid-high-earners-download" & @CRLF & _
"/tax-efficient-investing-capital-gains" & @CRLF & _
"/tax-efficient-investing-capital-gains-download" & @CRLF & _
"/pb_iht_guide" & @CRLF & _
"/pb-iht-download" & @CRLF & _
"/iht-guide" & @CRLF & _
"/iht-guide-download" & @CRLF & _
"/inheritance-tax" & @CRLF & _
"/inheritance-tax-download" & @CRLF & _
"/iht-free-isa" & @CRLF & _
"/make-isa-iht-free" & @CRLF & _
"/iht-free-isa-download" & @CRLF & _
"/aim-isa-guide" & @CRLF & _
"/aim-isa-guide-download" & @CRLF & _
"/eis-factsheet" & @CRLF & _
"/EIS-factsheet-download" & @CRLF & _
"/seis-factsheet" & @CRLF & _
"/seis-factsheet-download" & @CRLF & _
"/vct-factsheet" & @CRLF & _
"/vct-factsheet-download" & @CRLF & _
"/eis-knowledge-intensive" & @CRLF & _
"/uktn-download" & @CRLF & _
"/free-research-report-octopus-titan" & @CRLF & _
"/free-research-report-octopus-titan-download" & @CRLF & _
"/investment-ideas" & @CRLF & _
"/investment-ideas-download" & @CRLF & _
"/isa-iht-free-report" & @CRLF & _
"/isa-iht-free-report-download" & @CRLF & _
"" & @CRLF & _
"<!-- WWW SITE -->" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")