#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:www\d*|online|subl)*\.)?(?:mydomain|alternatedomain)\.com$"
Local $sString = "mydomain.com" & @CRLF & _
"www.mydomain.com" & @CRLF & _
"www.alternatedomain.com" & @CRLF & _
"www100.mydomain.com" & @CRLF & _
"online.mydomain.com" & @CRLF & _
"subl.mydomain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")