const regex = /^(?:(?:www\d*|online|subl)*\.)?(?:mydomain|alternatedomain)\.com$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:www\\d*|online|subl)*\\.)?(?:mydomain|alternatedomain)\\.com$', 'gm')
const str = `mydomain.com
www.mydomain.com
www.alternatedomain.com
www100.mydomain.com
online.mydomain.com
subl.mydomain.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}