$re = '/^(?:(?:www\d*|online|subl)*\.)?(?:mydomain|alternatedomain)\.com$/m';
$str = 'mydomain.com
www.mydomain.com
www.alternatedomain.com
www100.mydomain.com
online.mydomain.com
subl.mydomain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);