package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)=((?:<!\[CDATA\[.*?]]>|[^;])+)`)
var str = `prop1=value1;prop2=<![CDATA[String test='1234';int i=4;]]>;prop3=value3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}