$re = '/(\w+)=((?:<!\[CDATA\[.*?]]>|[^;])+)/';
$str = 'prop1=value1;prop2=<![CDATA[String test=\'1234\';int i=4;]]>;prop3=value3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);