using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*(.*?)((?<!\\)|(?<=\\\\))\*";
string input = @"*bold \*text*
*bold* text
** text*
*bold text*
** * \* *
*bold \\*text\*
*bold \*te\*x \\*t* *
efbfb *bold \*text* rgeb *gbrgv*
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}