import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*(.*?)((?<!\\\\)|(?<=\\\\\\\\))\\*";
final String string = "*bold \\*text*\n"
+ "*bold* text\n"
+ "** text*\n"
+ "*bold text*\n\n"
+ "** * \\* *\n"
+ "*bold \\\\*text\\*\n"
+ "*bold \\*te\\*x \\\\*t* *\n"
+ "efbfb *bold \\*text* rgeb *gbrgv*\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}