$re = '/\*(.*?)((?<!\\\\)|(?<=\\\\\\\\))\*/';
$str = '*bold \\*text*
*bold* text
** text*
*bold text*
** * \\* *
*bold \\\\*text\\*
*bold \\*te\\*x \\\\*t* *
efbfb *bold \\*text* rgeb *gbrgv*
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);