using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z-]+(\(
([0-9]+:[0-9]+)*\/
([0-9]+:[0-9]+)*\/*
([0-9]+:[0-9]+)*\/*
([0-9]+:[0-9]+)\))
[a-zA-Z-]*
";
string input = @"CDP-DG(16:0/16:01)
CL(10:0/10:0/13:0/18:0)
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}